CW-Windows-Logo-VerticalRecommended System Requirements for Optimal Performance

  • Processor: Quad-core or better (APU processor not supported)
  • RAM: 4GB or more
  • Network Connection (if networked) : 100MB or faster wired connection
  • Recommended Operating System for Church Windows v22 or newer:
    • 64-bit Operating Systems Only*
    • Windows® 10
    • Windows® 8.1
    • Windows® Server 2016
    • Windows® Server 2012 R2
  • Video: 1280×1024 standard, 1280×720 wide
  • Printer: laser or inkjet
  • Disk Space: 1 GB min, but 15% of total free

Printable Minimum/Recommended Church Windows Requirements

* CURRENT AND FUTURE CHURCH WINDOWS VERSIONS ARE ONLY OPERATIONAL ON 64-BIT MACHINES. IT IS IMPORTANT TO CHECK EACH COMPUTER’S SYSTEM REQUIREMENTS PRIOR TO INSTALLING THIS VERSION. “SYSTEM TYPE: x64-based PC” MUST DISPLAY IN WINDOWS® SYSTEM INFORMATION.

PLEASE NOTE: Microsoft® (and, therefore, Church Windows) has discontinued Support of Windows® XP and Server 2003 as of 03/2014 and Windows® Vista as of 04/2017.

Microsoft® will discontinue support of Windows® 7 and Server 2008 after January 14, 2020.

Microsoft Windows® Operating System Compatibility with Church Windows Software

This chart displays the compatibility between Church Windows versions with Microsoft Windows® Operating System versions.

You can always check the Microsoft Windows® Operating System Version on your computer by pressing the Windows key in the lower left of your keyboard and typing “winver” (As in Windows Version, typed without the quotes), then press Enter. The Windows® version will display.

Compare the Windows® version in the table below to determine which if newer Church Windows releases are compatible with your computer.

Microsoft Windows® Operating System

Windows® 8.1

Windows® 10

Windows® Server 2012 R2

Windows® 2016

Windows® 2019

Church Windows Version

15.11.x & Prior

N/S

N/S

N/S

N/S

N/S

16.13.x

Yes

N/S

N/S

N/S

N/S

17.14.x

Yes

N/S

N/S

N/S

N/S

18.15.x

Yes

Yes

Yes

Yes

Yes

19.16.x

Yes

Yes

Yes

Yes

Yes

20.17.x

Yes

Yes

Yes

Yes

Yes

21.18.x

Yes

Yes

Yes

Yes

Yes

22.19.x

Yes

Yes

Yes

Yes

Yes

(N/S = Not Supported)